Elevated Request Timeouts
Incident Report for Orbit
Resolved
This incident has been resolved.
Posted Jun 10, 2021 - 15:09 UTC
Investigating
We're experiencing an elevated level of request timeouts taking longer than 30 seconds to complete and are currently looking into the issue.
Posted Jun 10, 2021 - 14:57 UTC
This incident affected: Orbit Application and Orbit API.